How to run SubSupport on Mac/Linux

SubSupport is a Java program

SubSupport was made by Java programming language. Originally Java's intention was "Write once, Run everywhere".

But still there's some difference between each OS on which Java program runs. Especially SubSupport needs another softwares to run. It depends on the following.

  • JRE(Java Runtime Environment)
  • VLC Media Player
  • ffmpeg
  • chromedriver

Java Runtime Environment

SubSupport needs Java8 - Version 8u40 or later. Mac/Linux seem to have these versions as well. Anyway consult your OS distributor.

 

VLC Media Player

You can get VLC for Mac/Linux from the following site.

https://www.videolan.org/vlc/

ffmpeg

ffmpeg is optional. Without it SubSupport can run but you can't get waveform of the audio without it.

Download ffmpeg from this site for your OS.

Unzip downloaded zip file and put "ffmpeg" executable into plugins folder. You can delete ffmpeg.exe for Windows OS.

chromedriver

chromedriver is optional as well. Without it SubSupport can run.

But without it you get many tabs on default browser everytime you search some word on online-directionary. Chromedriver prevents it only for Google Chrome.

Download chromedriver from this site for your OS.

Unzip downloaded zip file and put "chromedriver" executable into plugins folder. You can delete chromedriver.exe for Windows OS.

投稿日:

Copyright© SubSupport , 2018 All Rights Reserved Powered by STINGER.